
 

  



Module Two: Introduction to Excel 2024 

Microsoft Excel 2024 offers a robust set of tools for organizing data, 

performing calculations, and creating professional reports. Its 

intuitive interface allows users to navigate workbooks efficiently, 

manage worksheets with ease, and access frequently used 

commands through the Ribbon and Quick Access Toolbar. 

Enhancements in this version improve customization, making it 

easier to tailor the workspace to specific needs. New features further 

streamline data analysis and collaboration, providing greater 

flexibility for both individual users and teams. With a refined layout 

and expanded functionality, Excel 2024 continues to be an essential 

tool for productivity and data management. 

 

 

Understanding Excel’s Interface and Navigation 

Understanding the layout and navigation tools in Microsoft Excel 2024 is essential for working 

efficiently and making the most of its features. A clear grasp of the interface helps streamline tasks, 

reduces time spent searching for tools, and allows for smoother data management and analysis. The 

interface is designed to be intuitive, with organized sections like the Ribbon, Formula Bar, and 

Worksheet Area, all working together to support data entry, formatting, and complex calculations. 

When you first open Excel 2024, you’ll see several key areas that make up the interface, each designed 

to help you work efficiently: 

• Title Bar: Located at the top of the window, it displays the name of your workbook and 

provides options to minimize, maximize, or close Excel. 

If you have knowledge, let others light their 

candles in it. 

Margaret Fuller 

 



 

• Ribbon: The main navigation panel filled with tabs like Home, Insert, and Formulas, each 

containing groups of related commands for formatting, data entry, and analysis.  

 

 

• Formula Bar: Positioned below the Ribbon, this is where you can enter or edit data, functions, 

and formulas. It also displays the contents of the selected cell. 

 

• Worksheet Area: The large grid made up of rows and columns where you input, organize, and 

analyze your data. This is where most of your work happens. 



 

• Status Bar: Found at the bottom of the window, it shows useful information like the average, 

sum, or count of selected cells, and includes view options and a zoom slider. 

 

 

Estimated Time  10 minutes 

Topic Objective To identify key layouts and navigation tools. 



Topic Summary The interface is designed to be intuitive, with organized sections like the 

Ribbon, Formula Bar, and Worksheet Area, all working together to support 

data entry, formatting, and complex calculations. 

Materials Required Worksheet 1: Excel Navigation Challenge 

Planning Checklist Provide enough worksheet printouts for all participants.  

Recommended Activity Have participants complete Worksheet 1: Excel Navigation Challenge.  

Discuss worksheet results. 

Stories to Share Share any personal, relevant stories. 

Delivery Tips Encourage everyone to participate. 

Review Questions Where is the status bar located? 

Where is the ribbon located? 

 

 

Creating, Saving, and Managing Workbooks 

Workbooks are the foundation of Microsoft Excel 2024, acting as containers for your worksheets, data, 

charts, and calculations. Each workbook can hold multiple worksheets, making it easy to organize 

related information within a single file. Understanding how to create, save, and manage workbooks 

efficiently is essential for staying organized, protecting your data, and improving workflow. Proper 

workbook management not only helps prevent data loss but also makes it easier to collaborate, share, 

and access your files when needed. 

Creating a New Workbook: 

Start a new workbook by selecting File > New and choosing Blank Workbook. This opens a fresh grid 

where you can begin entering data. Excel also offers pre-built templates for specific tasks like budgets 

or calendars, accessible from the New menu. 



 

Saving a Workbook: 

To save your work, go to File > Save As, choose a location, and enter a file name. Excel 2024 defaults to 

the .xlsx format, which supports most features. You can also save in other formats, like .csv or .pdf, 

depending on your needs. To quickly save changes, use Ctrl + S. 

 

AutoSave and Version History: 

If you're working from OneDrive or SharePoint, AutoSave automatically saves your changes in real-

time, reducing the risk of data loss. You can also access Version History to review or restore earlier 

versions of your workbook. 

Managing Workbooks: 



Excel makes it easy to manage multiple workbooks at once. Use File > Open to browse recent files or 

open multiple workbooks simultaneously. You can switch between open files using the tabs on your 

taskbar or through View > Switch Windows in the Ribbon. 

 

Closing and Exiting: 

To close a workbook without exiting Excel, select File > Close. If you want to close Excel entirely, click 

the X in the top-right corner or go to File > Exit. Excel will prompt you to save any unsaved work before 

closing. 

 

Estimated Time  10 minutes 

Topic Objective To recognize how to create, save, and manage workbooks.  

Topic Summary Workbooks are the foundation of Microsoft Excel 2024, acting as containers 

for your worksheets, data, charts, and calculations. 

Materials Required Worksheet 2: Workbook Management 

Planning Checklist Provide enough worksheet printouts for all participants. 

Recommended Activity Have participants complete Worksheet 2: Workbook Management. 

Discuss worksheet results. 

Stories to Share Share any personal, relevant stories. 

Delivery Tips Encourage everyone to participate. 

Review Questions What is a workbook? 

 



 

Working with Worksheets: Adding, Renaming, and Deleting 

Worksheets are the individual grids within a workbook where you enter and organize your data. In 

Microsoft Excel 2024, each workbook starts with one worksheet by default, but you can easily add, 

rename, or delete worksheets as your project grows. Effectively managing worksheets helps keep your 

data organized, whether you're handling budgets, reports, or complex data sets across multiple sheets. 

Adding Worksheets: 

To add a new worksheet, click the plus (+) icon next to the existing sheet tabs at the bottom of the 

screen. A new sheet, typically named Sheet2, Sheet3, and so on, will appear. You can also add a new 

worksheet by right-clicking an existing sheet tab and selecting Insert, then choosing Worksheet. 

 

Renaming Worksheets: 

Giving worksheets clear, descriptive names makes navigating your workbook much easier. To rename a 

worksheet, double-click directly on the sheet tab, type the new name, and press Enter. Alternatively, 

right-click the sheet tab, select Rename, enter the new name, and press Enter. Excel allows up to 31 

characters for worksheet names, but it's best to keep names concise. 

 

Deleting Worksheets: 



To remove an unwanted worksheet, right-click the sheet tab and select Delete. Excel will prompt you 

to confirm the deletion, especially if the worksheet contains data, as this action cannot be undone. Be 

sure to double-check before deleting important sheets. 

Rearranging and Duplicating Worksheets: 

To rearrange worksheets, simply click and drag the sheet tab to a new position within the workbook. 

To duplicate a worksheet, right-click the sheet tab, select Move or Copy, check the Create a copy box, 

and choose where you'd like the duplicate to appear. 

Color-Coding Worksheets: 

For easier navigation, you can color-code sheet tabs. Right-click the sheet tab, select Tab Color, and 

choose a color. This is particularly helpful when working with large workbooks, as it allows you to 

visually group related worksheets. 

 

 

Estimated Time  10 minutes 

Topic Objective To identify Worksheets and how to manage them. 

Topic Summary Worksheets are the individual grids within a workbook where you enter 

and organize your data. In Microsoft Excel 2024, each workbook starts 

with one worksheet by default, but you can easily add, rename, or delete 

worksheets as your project grows. 

Materials Required Worksheet 3: Working with Worksheets 



Planning Checklist Provide enough worksheet printouts for all participants. 

Recommended Activity Have participants complete Worksheet 3: Working with Worksheets. 

Discuss worksheet results. 

Stories to Share Share any personal, relevant stories. 

Delivery Tips Encourage everyone to participate. 

Review Questions What are worksheets? 

 

 

Using the Ribbon, Quick Access Toolbar, and Context Menus 

The Ribbon, Quick Access Toolbar (QAT), and Context Menus in Microsoft Excel 2024 are essential 

navigation tools that give you quick access to the features and commands you use most often. 

Understanding how these tools work and how to customize them can significantly improve your 

efficiency and make working in Excel smoother and faster. 

The Ribbon: 

The Ribbon is Excel’s primary navigation area, located at the top of the window. It’s organized into tabs 

like Home, Insert, Formulas, Data, and View, with each tab containing groups of related commands. For 

example, the Home tab includes formatting, alignment, and editing tools, while the Insert tab allows 

you to add charts, tables, and images. 

You can customize the Ribbon by right-clicking anywhere on it and selecting Customize the Ribbon. 

This allows you to add or remove commands, create custom tabs, and reorder existing tabs to suit your 

workflow. You can also collapse the Ribbon to give yourself more working space by clicking the small 

arrow in the top-right corner. 



 

Quick Access Toolbar (QAT): 

The Quick Access Toolbar sits above the Ribbon and provides one-click access to frequently used 

commands like Save, Undo, and Redo. You can personalize the QAT to include any commands you use 

regularly. 

To customize the QAT, click the dropdown arrow on the right side of the toolbar and select commands 

from the list, or choose More Commands to access the full customization options. You can also choose 

to display the QAT above or below the Ribbon, depending on your preference. 



 

Context Menus: 

Context menus provide quick access to relevant commands based on what you’re working on. These 

menus appear when you right-click on an element in Excel, such as a cell, chart, or worksheet tab. 

For example, right-clicking on a cell brings up options like Cut, Copy, Paste, Insert, Delete, and Format 

Cells. Right-clicking on a chart opens options for formatting the chart, changing the chart type, or 

adding chart elements. Context menus help you work faster by offering the most useful commands 

directly where you need them. 

Using Keyboard Shortcuts with the Ribbon and Menus: 

You can also use keyboard shortcuts to navigate the Ribbon and context menus. Press Alt to activate 

key tips, which display letters and numbers over Ribbon tabs and commands. Typing the corresponding 

key will open that tab or execute the command, allowing for faster, mouse-free navigation. 

Best Practices for Customization: 

Customizing the Ribbon and Quick Access Toolbar can help streamline your workflow and reduce the 

time spent searching for commands. Consider adding the tools you use most frequently, such as Print 

Preview, Sort & Filter, or Format Painter, to the QAT for easy access. 

 

Estimated Time  10 minutes 

Topic Objective To recognize essential tools in Excel that can improve efficiency.  



Topic Summary The Ribbon, Quick Access Toolbar (QAT), and Context Menus in Microsoft 

Excel 2024 are essential navigation tools that give you quick access to the 

features and commands you use most often. 

Materials Required Worksheet 4: Personalizing Excel’s Interface 

Planning Checklist Provide enough worksheet printouts for all participants. 

Recommended Activity Have participants complete Worksheet 4: Personalizing Excel’s Interface. 

Discuss worksheet results. 

Stories to Share Share any personal, relevant stories. 

Delivery Tips Encourage everyone to participate. 

Review Questions What does QAT stand for? 

Why is it beneficial to customize the Ribbon and other navigation tools? 

 

 

Exploring New Features in Excel 2024 

Microsoft Excel 2024 introduces several powerful new features designed to improve productivity, 

enhance data analysis, and offer more flexibility in how you work. These updates make it easier than 

ever to manage and present your data effectively, even if you're new to Excel. 

Dynamic Arrays Enhancements: 

Excel 2024 simplifies data manipulation with enhanced dynamic arrays. Functions like FILTER, SORT, 

and UNIQUE help you organize and analyze data quickly without needing complex formulas. These 

functions spill results into adjacent cells automatically, saving time and reducing manual work. 

Enhanced Charting with Dynamic Data: 

Charts in Excel 2024 now update automatically when your data changes, thanks to improved 

integration with dynamic arrays. New chart types and more intuitive formatting options help you 

present your data clearly and professionally. 

Improved Performance and Stability: 

Excel 2024 runs faster and smoother, especially when working with large datasets or complex 

workbooks. Opening files, running formulas, and refreshing PivotTables are all more efficient, helping 

you stay productive. 



Collaboration Enhancements: 

With improved real-time collaboration features, working with others is easier than ever. You can see 

who is editing a shared workbook, view live changes, and use enhanced comments to streamline 

communication. 

AutoSave and Version History Upgrades: 

AutoSave has been refined to capture changes more frequently, especially in cloud-based files. The 

improved Version History makes it simple to view, restore, or compare previous versions of your 

workbook. 

More Powerful Data Tools: 

Excel’s PivotTables and Conditional Formatting have been enhanced. New filtering options and 

expanded formatting rules allow you to analyze and visualize data more effectively without the need 

for complex steps. 

Accessibility and Interface Improvements: 

Excel 2024 has made strides in accessibility, improving screen reader support and keyboard navigation. 

The interface has also been streamlined with cleaner icons, enhanced contrast options, and an overall 

modern look. 

Templates and Productivity Boosters: 

A variety of new templates are available, including budgets, project trackers, and calendars. These 

ready-made templates help you start quickly and can be easily customized to meet your needs. 

 

Estimated Time  10 minutes 

Topic Objective To explore various new features in Excel 2024. 

Topic Summary Microsoft Excel 2024 introduces several powerful new features designed 

to improve productivity, enhance data analysis, and offer more flexibility 

in how you work. 

Materials Required Worksheet 5: New Features Practice 

Planning Checklist Provide enough worksheet printouts for all participants. 

Recommended Activity Have participants complete Worksheet 5: New Features Practice. 

Discuss worksheet results. 



Stories to Share Share any personal, relevant stories. 

Delivery Tips Encourage everyone to participate. 

Review Questions What are some new templates available in Excel 2024? 

 

 

Practical Illustration 

James had just started as a financial analyst when he was handed a very 

disorganized Excel report. Worksheets were cluttered, poorly named, and 

filled with redundant data, making navigation frustrating. As he attempted to 

insert a new sheet for analysis, he accidentally overwrote a key summary, 

unsure how to undo the mistake. Struggling to locate the right tools in the 

Ribbon and Quick Access Toolbar, he felt overwhelmed by the cluttered 

workbook and worried he wouldn’t be able to clean it up in time for his 

deadline. 

Determined to regain control, James explored Excel’s interface and navigation tools. He customized the 

Quick Access Toolbar to include essential shortcuts, used context menus to rename and organize 

sheets, and leveraged the Search bar to find unfamiliar functions instantly. With Excel 2024’s improved 

layout, he quickly transformed the chaotic workbook into a structured, easy-to-use file. By the next 

morning, his report was clear, organized, and ready for review—earning praise from his manager and 

proving that mastering Excel’s tools wasn’t just about efficiency, but success. 

  



Module Two: Review Questions

1) What is the primary function of the Ribbon in Microsoft Excel 2024? 

a) Displays the name of the workbook and window control buttons 

b) Provides a space for entering and editing formulas 

c) Serves as the main navigation panel with tabs containing related commands 

d) Shows statistical summaries like sum and average of selected cells 

The ribbon is the main navigation panel filled with tabs like Home, Insert, and Formulas, each 

containing groups of related commands for formatting, data entry, and analysis. 

2) What is the purpose of the Status Bar in Microsoft Excel 2024? 

a) Displays workbook name and window control buttons 

b) Provides a space to input and organize data 

c) Contains tabs like Home, Insert, and Formulas 

d) Shows information like sum, average, and count of selected cells, and offers view options 

The status bar shows useful information like the average, sum, or count of selected cells, and 

includes view options and a zoom slider. 

3) How can you quickly save changes to your workbook in Excel 2024? 

a) Press Ctrl + P 

b) Press Ctrl + S 

c) Use File > Save As and rename the file 

d) Select View > Switch Windows 

To quickly save changes, use Ctrl + S. 

4) What happens when AutoSave is enabled in Excel 2024? 

a) It automatically creates a new workbook every time changes are made 

b) It deletes previous versions of the workbook permanently 

c) It saves changes in real-time when working from OneDrive or SharePoint 

d) It only saves changes when you manually select File > Save 

If you're working from OneDrive or SharePoint, AutoSave automatically saves your changes in 

real-time, reducing the risk of data loss. 

  



5) How can you add a new worksheet in Microsoft Excel 2024? 

a) Click the plus (+) icon next to existing sheet tabs 

b) Press Ctrl + N to create a new worksheet 

c) Open the View tab and select "New Sheet" 

d) Use File > New Worksheet 

To add a new worksheet, click the plus (+) icon next to the existing sheet tabs at the bottom of 

the screen. 

6) Why would you color-code worksheet tabs in Excel 2024? 

a) To make the tabs look more visually appealing 

b) To visually group related worksheets for easier navigation 

c) To prevent other users from editing the worksheet 

d) To automatically sort sheets by color 

Color-coding is particularly helpful when working with large workbooks, as it allows you to 

visually group related worksheets.  

7) How can you customize the Quick Access Toolbar (QAT) in Excel 2024? 

a) Click the dropdown arrow on the QAT and select "More Commands" 

b) Right-click anywhere on the Ribbon and select "Customize the Ribbon" 

c) Open File > Options > View and select "Customize Toolbar" 

d) Drag and drop commands directly onto the QAT 

To customize the QAT, click the dropdown arrow on the right side of the toolbar and select 

commands from the list, or choose More Commands to access the full customization options. 

8) What is a key benefit of using context menus in Excel 2024? 

a) They replace the need to use the Ribbon entirely 

b) They automatically add frequently used commands to the QAT 

c) They are only available for formatting charts 

d) They allow users to access relevant commands quickly by right-clicking 

Context menus provide quick access to relevant commands based on what you’re working on. 

  



9) How do enhanced dynamic arrays improve data analysis in Excel 2024? 

a) They allow formulas to be entered without using the equals sign 

b) They automatically spill results into adjacent cells, reducing manual work 

c) They replace the need for charts and PivotTables 

d) They remove the need for conditional formatting 

These functions spill results into adjacent cells automatically, saving time and reducing manual 

work. 

10) What improvement in Excel 2024 makes working with charts more efficient? 

a) Charts now update automatically when data changes 

b) Users must manually refresh charts after data updates 

c) Chart formatting is now locked and cannot be changed 

d) All charts are now created using AI without user input 

Charts in Excel 2024 now update automatically when your data changes, thanks to improved 

integration with dynamic arrays.
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Sample Worksheet 1 
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Icebreaker: Excel Explorer’s Journey 

PURPOSE 

The goal of this icebreaker is to familiarize participants with the basics of Excel 2024 while engaging 

them in a fun and creative way. By metaphorically comparing Excel functions and features to tools and 

challenges in an explorer's journey, participants will explore both individual and collaborative aspects of 

learning a new software, easing any anxieties and creating a comfortable learning environment. 

MATERIALS REQUIRED 

• Excel 2024 on participants' computers 

• Printed maps of an imaginary world (one per participant) 

• Markers or pens 

• Imaginary "toolkit" cards which describe basic Excel functions (e.g., SUM, AVERAGE) 

• Physical or virtual sticky notes 

• Projector and screen (for in-person sessions) or screen-sharing capabilities (for virtual sessions) 

PREPARATION 

Create and print maps of an imaginary world, where different regions represent various Excel functions 

(e.g., "Sum Mountains", "Macro Forest"). Prepare "toolkit" cards with simple explanations of how each 

Excel function can be used (one set per participant). Set up a presentation slide with instructions and 

objectives of the icebreaker. For virtual sessions, prepare digital versions of the maps and toolkit cards, 

and ensure all participants can access Microsoft Excel 2024 or a simulated environment online. 

ACTIVITY  

Welcome participants and introduce the metaphor of an "Excel Explorer". Explain that each region on 

the map represents a different function or feature of Excel 2024, and their journey will involve learning 

how to use these to navigate challenges. Hand out the maps and toolkit cards to each participant. Assign 

each participant or small groups a starting region. Participants use the toolkit cards to solve a challenge 

at their starting region (e.g., use SUM to tally resources needed for the journey). Groups present their 

solutions and discuss how they used the Excel toolkits. Facilitate a short discussion on different 

approaches to the same problem. Introduce a group challenge where they must plan a route through 

multiple regions using different Excel functions to solve larger problems. Each group shares their journey 

and the Excel functions they employed. Discuss any difficulties encountered and how they overcame 

them. 

NOTE 
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To adapt this icebreaker for virtual training, use virtual breakout rooms for group discussions. Digital 

maps and toolkit cards can be shared through screen sharing or as pre-sent files. Encourage the use of 

chat and reaction tools to increase engagement.  

 

  

http://www.corporatetrainingmaterials.com/


© Corporate Training Material                                                      www.corporatetrainingmaterials.com 

           

 

 

http://www.corporatetrainingmaterials.com/


© Corporate Training Material                                                      www.corporatetrainingmaterials.com 

           

 

[N
am

e
] 

H
as m

astered the course 
M

icrosoft E
xcel 2024 

A
w

a
rd

ed
 th

is _
_

_
_

_
_

_
 d

a
y

 o
f _

_
_

_
_

_
e_

_
_

_
, 2

0
_

_
_

 

C
E

R
T

IF
IC

A
T

E
 O

F 
C

O
M

P
L

E
T

IO
N

 

P
resen

ter N
a

m
e a

n
d

 T
itle

 

http://www.corporatetrainingmaterials.com/

